ATI driver HOWTO

L' ambiente multimediale di slackware

Moderatori: rizla_, slacky-strike, redmarx

ATI driver HOWTO

Messaggioda rizla_ » mer apr 11, 2007 10:39 am

Come installare i driver ATI per poter sfruttare l' accelerazione grafica.

Eseguire il download dal sito ATI ( http://www.ati.com ) avendo cura di scegliere correttamente il proprio tipo di scheda videa. Supponiamo di utilizzare una 9800 pro.

La pagina alla quale vengo rediretto, dopo aver selezionato il tipo di scheda è la seguente:

http://ati.amd.com/support/drivers/linu ... adeon.html

A questo punto, potete scegliere il tipo di installazione:

- ATI Driver Installer consigliata, se non sapete il tipo di XFree / Xorg utilizzato

-XFree86 4.3 Drivers se usate la versione 4.3 di XFree

-X.Org 6.8 Drivers se usate Xorg versione 6.8


Come dicevo poc' anzi, useremo ATI Driver Installer

Scarichiamo il pacchetto da qualche parte sul nostro pc e leggiamo le "Installer Instruction" presenti qui:

https://a248.e.akamai.net/f/674/9206/0/ ... -inst.html

Tra i requirements e le note di questo documento, leggiamo:

Codice: Seleziona tutto
Kernel source code: Either the Kernel Source or Kernel Headers packages


Dovete avere OBBLIGATORIAMENTE i sorgenti del kernel, altrimenti l' installer non funzionerà.


Codice: Seleziona tutto
In order to use the fglrx internal AGP support, you have to make sure that the kernel agpgart support is not active, i.e. it is not compiled into the kernel and the kernel modules are not loaded. If the fglrx kernel module detects that the kernel agpgart support is active, it will automatically use that even if its internal AGP support is requested in order to avoid conflicts that can cause problems under some circumstances.


che ci suggerisce di disabilitare il supporto AGP all' interno del nostro kernel, per cui, se lo avete abilitato, ricompilate il kernel e disabilitatelo.


Codice: Seleziona tutto
XFree86-Mesa-libGL
libstdc++
libgcc
XFree86-libs
fontconfig
expat
freetype
zlib
gcc



Questi sono i pacchetti che dovete aver installato per la corretta installazione dei driver. Generalmente ci sono già tutti, ma in ogni caso è bene controllare ed installare i mancanti.

Una volta che tutti i requisiti sono soddisfatti, passiamo all' installazione vera e propria assegnando i permessi di esecuzione al file precedentemente scaricato

Codice: Seleziona tutto
chmod +x ati-driver-installer-8.35.5.run


e lanciamolo da un terminale grafico come utente root (xterm, gnome-terminal, konsole etc. etc)

Codice: Seleziona tutto
./ati-driver-installer-8.35.5.run


A questo punto dovrebbe essere apparire una finestra come questa:

Immagine


Scegliete, come da immagine, "Install Driver" e cliccate su "CONTINUE" in basso a destra. Successivamente, accettate i termini di licenza e proseguite.
A questo punto, comparirà una finestra come questa:

Immagine

Scegliete "AUTOMATIC" e cliccate su "CONTINUE".
Avete terminato l' installazione del driver, come vi verrà comunicato da questa immagine

Immagine

Cliccate "EXIT" per chiudere la finestra.
Ora configurate xorg.conf usando questo comando

Codice: Seleziona tutto
/usr/X11R6/bin/aticonfig --initial


e successivamente riavviate il sistema.

A questo punto verificate con dmesg che i driver siano stati caricati correttamente dal sistema o, piu' semplicemente, verificate con lsmod se compare il modulo fglrx e se viene utilizzato dal sistema. Con "lsmod |grep fglrx" dovrebbe comparire una cosa del genere:

Codice: Seleziona tutto
fglrx                 244732  7


That's all.

Ciao,
rizla_
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » lun set 17, 2007 5:02 pm

Ho seguito alla lettere le istruzioni, ma non sono riuscito a inserire il modulo fglrx nel kernel.
Nel log di installazione viene riportato:
Codice: Seleziona tutto
[Error] Kernel Module : Failed to install compiled kernel module

mentre dando il comando "modprobe fglrx" ottengo:
Codice: Seleziona tutto
FATAL: Error inserting fglrx (/lib/modules/2.6.22.6/kernel/drivers/char/drm/fglrx.ko): Operation not permitted
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » lun set 17, 2007 5:09 pm

Ciao,

non bastano queste informazioni.

Versione dei driver ? Versione del kernel ?

Ciao,
rizla_
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » lun set 17, 2007 5:15 pm

L'installer è ati-driver-installer-8.40.4-x86.x86_64.run e il kernel, come puoi vedere dal secondo messaggio d'errore è il 2.6.22.6.
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » lun set 17, 2007 5:21 pm

Da me funzionano con lo stesso kernel e la stessa versione dei driver.

Cosa dice

Codice: Seleziona tutto
ls -lart /lib/modules/2.6.22.6/kernel/drivers/char/drm/fglrx.ko


Altra cosa: la versione del GCC che hai usato per compilare il kernel , è la stessa di quella che stai usando per gli ATI ?
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » lun set 17, 2007 5:28 pm

Codice: Seleziona tutto
bash-3.1# ls -lart /lib/modules/2.6.22.6/kernel/drivers/char/drm/fglrx.ko
-rw-r--r-- 1 root root 874424 2007-09-17 18:26 /lib/modules/2.6.22.6/kernel/drivers/char/drm/fglrx.ko
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » lun set 17, 2007 5:29 pm

La versione del GCC è la stessa ?
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » lun set 17, 2007 5:30 pm

Si, ho usato il gcc 4.1.2 per entrambi.
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » lun set 17, 2007 5:35 pm

Ok,

il file /etc/modules ha qualche riferimento ai moduli fglrx, radeon o quant' altro ?
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » lun set 17, 2007 5:42 pm

Il file /etc/modules non esiste e dentro modprobe.conf non c'è scritto nulla, cioè, c'è scritto solo che il suo uso è deprecato e bisogna usare la cartella /etc/modprobe.d al suo posto.
Indovina un pò? Dentro /etc/modprobe.d c'è un altro file modprobe.conf con lo stesso identico messaggio dell'altro! Oltre a 2 file: isapnp e blacklist.
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » lun set 17, 2007 9:32 pm

Ok, non è quello il problema...
A questo punto, prova a cancellare il modulo /lib/modules/2.6.22.6/kernel/drivers/char/drm/fglrx.ko e riavvia l' installer dei driver ATI, vediamo se cambia qualcosa..

Ciao,
rizla_
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » mar set 18, 2007 6:15 pm

Sai quante volte l'avrò fatto? :(
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda rizla_ » mar set 18, 2007 10:53 pm

Controlliamo il file fglrx-install.log e il /var/log/Xorg.0.log , cosa dicono ?

Altra cosa: il kernel ha il radeonfb abilitato ? il drm ?

Se si, toglili

# CONFIG_FB_RADEON is not set

# CONFIG_DRM is not set

Ultima cosa: stai cercando di installare i driver per la prima volta oppure li avevi già installati e da dopo qualche modifica hai riscontrato il problema ?
Avatar utente
rizla_
Amministratore
Amministratore
 
Messaggi: 1129
Iscritto il: ven set 06, 2002 7:09 pm

Messaggioda redmarx » mer set 19, 2007 4:45 pm

Si, il drm è attivato mentre il frame buffer no. Comunque ho installato altre volte i drivfer ati con il drm attivato (e anche col supporto agp attivato) e non mi ha dato mai problemi.
Comunque, si è la prima volta che li installo da quando ho intallato la slack 12.
Il log d'installazione ora non ce l'ho sotto mano, ma diceva che i driver forniti col pacchetto non sono della stessa versione del kernel e che quindi deve ricompilarseli; dopo aver controllato la presenza della directory con i sorgenti del kernel inizia la compilazione e al suo termine(senza errori) stampa un messaggio in cui si dice che l'installer sta cercando di caricare il modulo fglrx appena compialto in memoria. Subito dopo l'errore che ho postato.
Ora disabilito pure il drm e provo a reinstallare i driver.
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Messaggioda redmarx » mer set 19, 2007 5:08 pm

Ok, grazie per la dritta, era colpa del DRM attivato nel kernel. Ora l'installazione va alla grande e il modulo si inserisce senza problemi.
Volevo provare se funzionava l'accellerazione ma guarda cosa ottengo:
Codice: Seleziona tutto
redmarx@darkstar:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  162 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  33
  Current serial number in output stream:  33

Che potrà essere?
redmarx
Super guru
Super guru
 
Messaggi: 798
Iscritto il: sab set 15, 2007 11:45 am
Località: Manoppello

Prossimo

Torna a Slackware - Multimedia

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron